Search

Recent Posts

Tags


« | Main | »

Resolving Hobo 1.4 and Rails 3.1 errors

By Dale Reagan | April 1, 2012

Well, at least ‘startup’ errors on a ‘fresh’ install of Hobo 1.4 and Rails3.1…

Hobo 1.4 and Rails 3.1 –  This should be on the Hobo 1.4 docs page  – I first encountered this when working with Rails 3.2 – the fixes include getting some sort of Javascript installed on your system.

Notes
— Hobo 1.4 pre requires Rails 3.1.x
— Javascript issue workaround as described below worked/tested on Centos 6.1

— The good news, use this approach once and subsequent ‘hobo new projectNNN’ seem to complete without issues… (your mileage may vary…)

1) gem install rails -v 3.1

2) gem install hobo –pre

3) hobo new test14  (will Error out due to ‘missing’ gems)

4) edit test14/Gemfile and add:

gem 'execjs'
gem 'therubyracer'

4a)  I also ‘installed’ these gems…

gem install execjs
gem install therubyracer

5) hobo new test14 ## You will be prompted to replace files
– Keep the Gemfile and
– accept overwrites for everything else

6) cd test14

7) rails s

8) point your browser at the instance…

The above suggests the need to:
a) add above gems to ‘default’ for Hobo?
b) add a hobo command line option to include ‘special/missing’ gems?

Topics: Problem Solving, ROR, Unix-Linux-Os, Web Technologies | Comments Off on Resolving Hobo 1.4 and Rails 3.1 errors

Comments are closed.


________________________________________________
YOUR GeoIP Data | Ip: 73.21.121.1
Continent: NA | Country Code: US | Country Name: United States
Region: | State/Region Name: | City:
(US only) Area Code: 0 | Postal code/Zip:
Latitude: 38.000000 | Longitude: -97.000000
Note - if using a mobile device your physical location may NOT be accurate...
________________________________________________

Georgia-USA.Com - Web Hosting for Business
____________________________________